R-Delivery

Welcome!
Thank you for purchasing our AZ-Delivery ESP32 Lolin32. On the following

pages, you will be introduced to how to use and set up this handy device.

Have fun!
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Introduction

Lolin32 is the ESP32 development board. Like other ESP32 boards, it also
has a 32-bit dual-core microcontroller which operates at 240MHz, has 4MB
of flash storage. It can be programmed in a range of languages, such as
microPython, LUA, mod. C/C++ in Arduino IDE, just like any other
microcontroller. It can be powered via lithium polymer batteries with a
500mA max charging current or via micro USB. The firmware that comes
with this board accepts AT commands by default. It is equipped with WiFi
and Bluetooth. In addition to that, it includes an FTDI FT231x, which
converts USB to serial and enables a computer to program and

communicate with the microcontroller.

This module does not use the WROOMS32 module with built-in flash memory
but has the ESP32 chip, the 4MByte flash memory, and the antenna built
directly on the board. Thus the width could be reduced by one grid

dimension. So this module can be used directly on a simple breadboard.

Another advantage of this module is the built-in charge controller for 3.7V
LiPo batteries. The module has a JST 2.0 mm socket for connecting a
battery. However, the module also has disadvantages. There is no 5V
connection and the power supply can only be done via USB or a battery.
There are also fewer connections out. There are 19 inputs/outputs and 4
inputs. A LED built on the module can be controlled by GPIO22.
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Specifications

Power supply 2.2V to 3.6V

Operating voltage 3.3V

Logic level 3.3V

Mounting holes diameter 2 holes, 3mm diameter

Integrated 802.11 BGN WiFi transceiver

Integrated dual-mode Bluetooth

4MB Flash Memory

Maximum serial baud rate 256000bps

Dimensions 50x25mm (1.97x0.98in)
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The pinout

The ESP32 Lolin32 has 26 pins. The pinout is shown in the following image:

builtin LED connected to GPI022

3.3V

: =1 [ GPio22 [intLED
-] 21| cPio19 | Miso
: ; =1 [Grio23 [ mos
RTC-5 s%135" 3 =1 [eprio1s [ cLk
RTC-9 | Touch 9 5 GPI005 | 58
RTC-8 | Touch 8 5 GPIO17
RTC-6 | DAC1 s, GPIO16 |
RTC-7_| DAC2 )| Touch 0 [ RTC-10 Ji2c1 cL[sD D1 [HspPiHD|

RTC-17 | Touch 7
HSPICL | SD CLK | RTC-16 | Touch 6
HSPIQ |SDD2 |RTC-15 | Touch 5 \

GPI0O00 Touch 1 | RTC-11 | 12C1 DA
GPI002 Touch 2 | RTC-12 | 12C2CL [ SD DO |HSPIWP
GPIO15 Touch 3 | RTC-13 | 12C2 DA| SD CMD| HSPICS
GPIO13 | ADC2-4 | RTC-14 | SDD3 |HSPID

blue LED on when charging LiPo Batt.
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How to set-up Arduino IDE

If the Arduino IDE is not installed, follow the link and download the
installation file for the operating system of choice. The Arduino IDE version
used for this eBook is 1.8.13.

Download the Arduino IDE

Windows installer, for Windows 7 and up
Windows ZIP file for non admin install

ARDUINO 1.8.13 Windows app Requires Win 810r 10 FBGet
The open-source Arduino Software (IDE) makes it easy to

write code and upload it to the board. It runs on Mac OS X 10.10 or newer

Windows, Mac OS X, and Linux. The environment is

written in Java and based on Processing and other open- - .

source software Linux 32 birs

This software can be used with any Arduino board Linux 64 bits

Refer to the Cetting Started page for Installation Linux ARM 32 bits

instructions Linux ARM 64 bits

Release Notes
Source Code
Checksums (sha512)

For Windows users, double click on the downloaded . exe file and follow

the instructions in the installation window.


https://www.arduino.cc/en/Main/Software
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For Linux users, download a file with the extension . tar. xz, which has to

be extracted. When it is extracted, go to the extracted directory and open

the terminal in that directory. Two . sh scripts have to be executed, the first

called arduino- linux-setup.sh and the second called install. sh.

To run the first script in the terminal, open the terminal in the extracted

directory and run the following command:
sh arduino-linux-setup.sh user_name

user_name - is the name of a superuser in Linux operating system. A
password for the superuser has to be entered when the command is

started. Wait for a few minutes for the script to complete everything.

The second script, called install. sh, has to be used after the installation
of the first script. Run the following command in the terminal (extracted

directory): sh install.sh

After the installation of these scripts, go to the ALl Apps, where the

Arduino IDE is installed.

Calendar calibre Catfish Fil



R-Delivery

Almost all operating systems come with a text editor preinstalled (for
example, Windows comes with Notepad, Linux Ubuntu comes with
Gedit, Linux Raspbian comes with Leafpad, etc.). All of these text

editors are perfectly fine for the purpose of the eBook.

Next thing is to check if your PC can detect an Atmega328p board. Open
freshly installed Arduino IDE, and go to:
Tools > Board > {your board name here}
{your board name here} should be the Arduino/Genuino Uno, as it can

be seen on the following image:

@ sketch_novl12a | Arduino 1.8.9 (Windows Store 1.8.21.0) — ] K
File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch

sketch_novi 23 Fix Encoding & Reload

1 void Manage Libraries... Ctrl+Shift+1 "

. Serial Manitar Ctrl+Shift+M

- /1| seral plotter Ctrl+ShiftsL - = 7

> WiFi101 / WiFiNIMA Firmware Updater

4 } Board: "Arduino/Genuine Uno" Boards Manager...

= Port b Arduino AVR Boards
E e "1 Get Board Info Arduino Yin

0/ VO1cC *  Arduino/Genuino Uno
7 / / BigrammecRall RISk Arduino Duemilanave or Diecimila
" Burn Beotloader A s

The port to which the Atmega328p board is connected has to be selected.
Go to: Tools > Port > {port name goes here}
and when the Atmega328p board is connected to the USB port, the port

name can be seen in the drop-down menu on the previous image.

-8-



R-Delivery

If the Arduino IDE is used on Windows, port names are as follows:

@' sketch_nov12a | Arduino 1.8.9 (Windows Store 1.8.21.0) — O x
File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
sketch_novlZz Fix Encoding & Reload

: . ibrari i ~
1 void Manage Libraries... Ctrl+Shift+|

Senal Monitor Ctrl+Shift+M
2 [7| seriotpiotter Ctrl+ShiftsL - = 7
3 WiF101 7 WiFiNINA Firmware Updater
4} . : .

Board: "Arduino,/Genuino Uno *
5 Port: "COM3" : Serial ports
- . Get Board Info COmM1
6 void

v coms

7 Programmer: "AVRISP mkll"

Burn Bootloader

[/ 2,"

For Linux users, for example, port name is /dev/ttyUSBx, where x

represents integer number between 0 and 9.
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Installing the ESP32 Board in Arduino IDE

To install ESP32 add-on in Arduino IDE first open Arduino IDE, than go to
File > Preferences:

7 .
Preferences @
Settings | Netwark

Sketchbook location:

C:\Users\Korisnik\Documents\Arduino

Editor language: :System Default - (requires restart of Arduino)
Editor font size: 12

Interface scale: Automatic | 100 % (requires restart of Arduino)

Theme: Default theme (requires restart of Arduino)

Show verbose output during: [| compilation 7] upload

Compiler warnings: lNone -

[ Display line numbers [] Enable Code Folding

Verify code after upload [ Use external editor

Check for updates on startup Save when verifying or uploading

[7] Use accessibility features

Additional Boards Manager URLs: |https://d|.espressif.com/dl/package_esp32_index.json
More preferences can be edited directly in the file
Ci\sersKarisnik\AppDataLocal\Arduino 15\preferences. txt

(edit only when Arduino is not running)

[ OK ” Cancel

In Additional Boards Manager URLs box enter the next URL:
https.//dl.expressif.com/dl/package _esp32_index.json

Than go to Tools > Board > Boards Manager and search for ESP32 and

press the install button for esp32 by Espressif Systems. After a few seconds
the ESP32 is installed.

-10 -
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Now, the board can be selected in the boards menu:

Ielin32_temp | Arduine

File Edit Sketch

lolin32_temp

cplu

uinté_t tempr|

void setup()
serial.begi

locp() 1|
Serial.prin|

// Convert
Serial.
Serial.
delay(5000);

WEMOS LOLIN32

Auto Format

Archive Sketch

Fix Encoding & Reload
Manage Libraries..
Serial Monitor

Serial Plotter

WiFil01 / WiFiMINA Firmware Updater

Board: "WEMOS LOLINZ2"

Upload Speed: "921600"

CPU Frequency: "240MHz (WiFi/BT)"
Flash Frequency: "80MHz"

Partition Scheme: *Default”

Port; "COMS"

Get Board Info

Programmer: "AVRISP mkdl"

Burn Bootloader

Boards Manager..
s
ESP32 Wrover Module
ESP32 Pico Kit
TinyPICO
MagicBit
Turta IoT Node
TTGO LoRa32-OLED V1
TTGOTL
XinaBox CW02
SparkFun ESP32 Thing
u-blox NINA-W10 series (ESP32)
Widora AIR
Electronic SweetPeas - ESP320
Nane32
LOLIN D32
LOLIN D32 PRO
WEMOS LOLINZ2
Dongsen Tech Pocket 32
WeMos WiFi&Bluctooth Battery
ESPea32
Neduino Quantum
Nede32s
Hornbill ESP32 Dev
Hernbill ESP32 Minima
FireBestle-ESP32

is used in

this project.

Now, the ESP32 board is ready for code to be uploaded.

-11 -
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Sketch examples

The ESP32 Lolin32 needs a micro USB cable to allow a computer to

program and communicate with the microcontroller.

Example with DS18B20

// Measure the temperature of your pool or pond with DS18B20

// and report it in your local WiFi

// Server

#include <WiFi.h>

#include <WiFiClient.h>

#include <WebServer.h>

#include <ESPmDNS.h>

const char* SSID = " your SSID ",
const char* PASSWORD = " your password
WebServer server(80);

//5ensor
#include <OneWire.h>

#include <DallasTemperature.h>

// Data wire is plugged into port 22 on the Lolin32,

resistor
#define ONE_WIRE_BUS 22

remember 4k7 pull-up

// Setup a oneWire instance to communicate with any OneWire devices

OneWire oneWire(ONE_WIRE_BUS);

-12 -
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// Pass our oneWire reference to Dallas Temperature.
DallasTemperature sensors(&oneWire);

void setup() {

// Server
Serial.begin(115200);
WiFi.mode(WIFI_STA);
WiFi.begin(SSID, PASSWORD);

while (WiFi.status() != WL_CONNECTED) {
delay(500);
Serial.print(".");
}
Serial.println("");,
Serial.printf("Connected to %s.\n", SSID);
Serial.printf("IP-Address: %s.\n", WiFi.localIP().toString().c_str());

if (MDNS.begin("Lolin32")) {
Serial.println("MDNS-Responder started.");

server.on("/", handleRoot);

server.onNotFound(handleNotFound);

server.begin();
Serial.println("HTTP-Server started.");

-13 -
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// Sensor
Serial.println("Dallas DS18B20 Temperature ");

// Start up the library
sensors.begin();

void loop() {
// Sensor

// call sensors.requestTemperatures() to issue a global temperature

// request to all devices on the bus

Serial.print("Requesting temperatures...");

sensors.requestTemperatures(); // Send the command to get temperatures

Serial.println("DONE");

// After we got the temperatures, we can print them here.

// We use the function ByIndex, and as an example get the temperature from
the first sensor only.

Serial.print("Temperature for the device 1 (index 0) is: ");

float tempC = sensors.getTempCByIndex(0);

Serial.println(tempC);

delay(5000);

// Server
server.handleClient();
server.on("/Sensor", HTTP_GET, []1() {
String message = "<!doctype html>\n";
message += '"<html>\n";

message += " <head>\n";

message += " <tit1le>ESP32 Thermometer / Hygrometer</title>\n";
message += " </head>\n";

message += " <body>\n";

message += " <hi1>Temperature: ";

message += String(sensors.getTempCByIndex(0), 2);
message += " &#8451;</h1>\n";
message += " </body>\n";

-14 -
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message += "</html>\n";
server.send (200, "text/html", message);

1)

void handleRoot() {
server.send(200, "text/plain", "Here 1is your Lolin32!");

void handleNotFound() {
String message = '"path ";
message += server.uri();
message += " not found.\n";
server.send(404, "text/plain", message);

-15 -
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The output should be as in the following image:

@ com4 = O X

Senden

.ets Jqun 8 2016 00:22:57

22:30:53.038 —>

22:30:53.038 —>» rst:0xl (POWERON_RESET) sboot:0x13 (SPI_FAST_FLASH_BOOT)
22:30:53.038 -> configsip: 0, SPIWP:Oxee

22:30:53.038 -> clk drv:0x00,q drv:0x00,d drv:0x00,cs50_drv:0x00,hd drv:0x00,wp drv:0x00
22:30:53.038 -> mode:DIO, clock div:1l

22:30:53.038 -> load:0x3fff0018,1en:4

22:30:53.085 -> load:0x3fff001c,1en:1044

22:30:53.085 —> 1oad:0x40078000,1en:8896

22:30:53.085 -> load:0x40080400,1len:5816

22:30:53.085 -> entry 0x400806ac

22:30:53.928 -> .

22:30:53.928 —> Connected to XITYLIGHT206194.

22:30:53.928 -> IP-Address: 192.168.178.92.

22:30:53.928 -> MDNS-Responder started.

22:30:53.928 -> HTTP-Server started.

22:30:53.975 -> Dallas DS18B20 Temperature

22:30:53.975 -> Requesting temperatures...DONE

22:30:54.069 -> Temperature for the device 1 (index 0) is: 23.00
22:30:59.065 -> Requesting temperatures...DONE

22:30:59.159 -> Temperature for the dewvice 1 (index 0) is: 22.94
22:31:04.209 -> Requesting temperatures...DONE

22:31:04.303 -> Temperature for the device 1 (index 0) is: 22.94
22:31:09.314 -> Requesting temperatures...DONE

22:31:09.408 -> Temperature for the device 1 (index 0) is: 22.94
22:31:14.463 -> Requesting temperatures...DONE

22:31:14.557 -> Temperature for the device 1 (index 0) is: 22.94

[] Autoscroll [] Zeitstempel anzeigen | Sowohl NL als auch CR | 115200 Baud v Ausgabe laschen

Note: Set baud rate to 115200.

-16 -
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WiFi works even when the micro USB cable is not connected. Simply enter
the IP address in your browser followed by /Sensor.
When not connected to the computer, the Serial Monitor of the Arduino IDE

does not get the information.

@ ESP32 Thermometer / Hygromet X +

< C A Nichtsicher | 192.168.178.92/Sensor * » Q@

Temperature: 22.94 °C

-17 -
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Example with BME280

#include <Wire.h>
#include <SPI.h>
#include <Adafruit_Sensor.h>

#include <Adafruit_BME280.h>

#define BME_SCK 18 //use these pins for hardware SPI
#define BME_MISO 19
#define BME_MOSI 23

#define BME_CS 5

Adafruit_BME280 bme; // I2C
//Adafruit_BME280 bme(BME_CS); // hardware SPI

//Adafruit_BME280 bme(BME_CS, BME_MOSI, BME_MISO, BME_SCK); // software SPI

unsigned long delayTime;

void setup() {
Wire.begin();
Serial.begin(9600);
while(!Serial); // time to get serial running
Serial.println(F("BME280 test"));
// default settings

unsigned status;

-18 -
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Wire.begin(26,27); //add this 1line for I2C with SDA=26 and
SCL=27
status = bme.begin(); //default is Ox77; otherwise

bme.begin(0x76)
if (!status) {

Serial.println("Could not find a valid BME280 sensor, check wiring,
address, sensor ID!");

Serial.print("SensorID was: 0x"); Serial.println(bme.sensorID(),16);

Serial.print(" ID of OXFF probably means a bad address, a BMP
180 or BMP 085\n");

Serial.print(" ID of Ox56-0x58 represents a BMP 280,\n");
Serial.print(" ID of Ox60 represents a BME 280.\n");
Serial.print(" ID of Ox61 represents a BME 680.\n");

while (1) delay(10);

Serial.println("-- Default Test --");
delayTime = 5000;

Serial.println();

void loop() {
printvValues();

delay(delayTime);

-19 -
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void printvValues() {

Serial.
Serial.
Serial.
Serial.
Serial.
Serial.
Serial.

Serial.

print("Temperature = ");
print(bme.readTemperature());
println(" *C");

print("Pressure = ");
print(bme.readPressure() / 100.0F);
printin(" hPa");

print("Humidity = ");

print(bme.readHumidity());

Serial.println(" %");

Serial.

println();

-20 -
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@ com4 = O X
Senden |
18:27:40.600 —> Temperature = 25.11 *C &
18:27:40.600 —> Pressure = 1026.73 hPa
18:27:40.645 —> Humidity = 33.91 %
18:27:40.645 ->
18:27:45.625 —-> Temperature = 25.11 *C
18:27:45.625 -> Pressure = 1026.76 hPa
18:27:45.625 —> Humidity = 34.29 %
18:27:45.672 —>
18:27:50.612 -> Temperature = 25.11 *C
158:27:50.612 —> Pressure = 1026.74 hPa
18:27:50.659 -> Humidity = 35.28 %
18:27:50.659 >
18:27:55.625 —> Temperature = 25.12 *C
18:27:55.625 —-> Pressure = 1026.76 hPa
18:27:55.625 -> Humidity = 35.54 %
18:27:55.674 —>
18:28:00.632 —> Temperature = 25.11 *C
18:28:00.632 —> Pressure = 1026.76 hPa
18:28:00.632 —> Humidity = 34.28 %
18:28:00.678 ->
18:28:05.607 —> Temperature = 25.12 *C
18:28:05.607 -> Pressure = 1026.78 hPa
18:28:05.654 —> Humidity = 35.94 %
18:28:05.654 ->
18:28:10.641 -> Temperature = 25.11 *C
18:28:10.641 -> Pressure = 1026.78 hPa
18:28:10.641 -> Humidity = 34.78 %
18:28:10.641 >
W

Autoscroll Zeitstempel anzeigen

|Sowohl NL als auch CR | | 9600 Baud

L

Ausgabe lgschen

Note: This works for 12C on pins 26 and 27 and could also be used (with
minor modifications) for SPI. Sketch and Libraries are from Adafruit (US).

-21 -
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Now it is the time to learn and make your own projects. You can do that with
the help of many example scripts and other tutorials, which can be found on

the Internet.

If you are looking for the high quality microelectronics and
accessories, AZ-Delivery Vertriebs GmbH is the right company to get
them from. You will be provided with numerous application examples,
full installation guides, eBooks, libraries and assistance from our

technical experts.

https://az-delivery.de

Have Fun!
Impressum

https://az-delivery.de/pages/about-us
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